Activation Issue: The server could not be reached. Details: N2 C0
How to resolve the N6 C0 activation issue
Issue
When trying to activate KeyShot, you may get the following error.
The server could not be reached. Details: N2 C0
Environment Details
- KeyShot
Cause
-
The error N2C0 means that the remote server closed the connection prematurely, before the entire reply was received. This usually points towards a connection issue.
This is most likely due to the Firewall settings.
Resolution
First,
Could you please add the following KeyShot URLs to the Firewall Whitelist for the organization and bypass them from TLS inspections?
• *.keyshot.io
• *.keyshot.com
• https://login-configuration.keyshot.com
• https://login.keyshot.com
• https://app.keyshot.com
• https://cognito-idp.us-east-2.amazonaws.com
Note: Contact your Network IT department to assist in adding these entries.
If the error persist, please try the following:
Could you please try to rule out firewall blocks: Press Win+R → wf.msc → Outbound Rules.Look for any Block rule targeting KeyShot/KeyShot Studio (or its “Auth/Login” helper keyshot_auth_handler.exe for KeyShot 2025.3 or prior) and disable it.
Also check Windows Defender Firewall Properties → [Domain/Private/Public] Profile → Outbound connections is set to Allow (default).
If the proxy is using SSL inspection, please make sure that the URLs mentioned above are excluded from the inspection/bypass ed.
Security suites (Kaspersky, Bitdefender, ESET, etc.) with “HTTPS scanning” can break TLS and cause timeouts. Temporarily disable SSL inspection/HTTPS scanning and re-test the issue.
Just to be safe, please ensure Windows date/time and time zone are correct, since a bad clock might cause TLS failures/timeouts.
If the issue is still not resolved, please create a ticket through our support portal.