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FlexNet Licensing error:-1,359

Troubleshooting 

Issue

When trying to connect to the Floating License Server, you may get an error in KeyShot with the following error:

Error Code: -97,121 The desired vendor daemon is down

accompanied by the error in the luxion.log

FlexNet Licensing error:-1,359
System Error:2 No such file or directory
Using license file "C:\flexlm\license.dat"

or

LUXION exited with status 27 (No features to serve)
LUXION daemon found no features.  Please correct
license file and re-start daemons.

Environment Details

  • KeyShot Floating License

Cause

If the error is only "Error code: -97, The desired vendor daemon is down." the solution could be to simply reboot the machine hosting the floating license.
If that does not help, the license server can either not find any features or the license file.
Please find the floating log file.

How to find the Log File.
     1. Start the Luxion License Server.
     2. Go to the Install License tab.
     3. Click License Folder.
               · A folder will open.
     4. Send the LUXION.log file Located in that folder.


If it contains either of the above errors, please try the following.

Resolution

LMTools might not reading the correct license file.

In LMTools under the 'Start/Stop/Reread' tab, at the bottom of the window you will see the file path to where the license is located.

Make sure the file path leads to the correct location. There can be multiple licenses in this area, so please be sure the correct license is being used.You can check and make any changes by selecting the 'Config Services' tab and clicking the 'Browse' button.

Enter the correct file path and select the desired license file.
Save any changes made and close LMTools.
Reboot the server host and reopen LMTools tools to confirm the changes have been saved.

You can restart the Luxion License Server through LMTools to bring everything back online.

License file is being read incorrectly

Lastly, you could try a fresh floating install.

How to do a Fresh Install of KeyShot floating license.

  1. Open Luxion License Server software.

  2. Click on the Install License tab.

  3. Click on the License Folder button.

  4. Click on Stop Service if it's running.

    1. Once the Service has stopped close your Luxion License serve software.

  5. Go to the License folder and delete all files in the folder.

    1. You can move them to another folder if you would like to keep them backed up.

  6. Launch Luxion License Server software.

  7. Click on the Install License tab

    1. (The license field should be empty)

  8. Download your license file from your email, or from a saved location.

  9. Click the New License button.

    1. Navigate to your KeyShot floating license file.

  10. Service be created and the license should start up.


Error Persits

If the error persists, please create a copy of the license file and rename it to license.dat and place it in "C:\flexlm\license.dat"
If the issue is still not resolved, please create a ticket through our support portal and send us the LUXION.log