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KeyShot Freezes When Importing Files

Resolving freezes caused by file synchronization with OneDrive or network drives.

Issue

When attempting to open or import files into KeyShot, the program becomes unresponsive and freezes. The application remains hung until it is closed using Task Manager.

Environment

  • Product: KeyShot

  • Platform: Windows

  • Version: All supported versions

Cause

KeyShot installation or Resource Folders are stored on a network or synchronized (e.g., OneDrive). Synchronization icons (e.g., checkmarks) in File Explorer indicate the folders are being managed by OneDrive. When the files are not available locally, KeyShot may freeze while attempting to access them.

Resolution

To resolve the issue, ensure KeyShot installation and Resource Folders are stored locally, not on a synchronized or network drive.

  1. Keep local copies of synchronized folders:

    • Right-click the KeyShot folders with cloud checkmarks in File Explorer.

    • Select “Always keep on this device” to ensure files are available offline.

  2. Verify KeyShot installation path:

    • Installed Just For Me:

      • C:\Users\<username>\AppData\Local\KeyShot or %UserProfile%\Local\KeyShot

      • Starting with KeyShot Studio 2025.2:
        C:\Users\<username>\AppData\Local\Programs\KeyShot Studio

    • Installed For Everybody:

      • C:\Program Files\KeyShot Studio or %ProgramFiles%\KeyShot Studio

  3. Verify Resource Folder path:

    • Installed Just For Me:

      • %UserProfile%\Documents\KeyShot Studio

      • C:\Users\<username>\Documents\KeyShot Studio

    • Installed For Everybody:

      • C:\Users\Public\Documents\KeyShot Studio

      • %Public%\Documents\KeyShot Studio

  4. Confirm all above folders are set to be local only, not cloud-synced.