Unable to Login to your KeyShot Cloud Account

When trying to login to your KeyShot Cloud Account, a perpetual spinning circle appears along with the message "Connecting to your KeyShot Cloud Account"

Issue

When trying to login to a KeyShot Cloud Account, or purchase KeyShot from the webstore, the following message appears along with a spinning circle that never goes away. Users are not able to login.

Environment Details

  • KeyShot website

Cause

  • Returning customers may have some old files cached in their browsers as changes to the website were deployed. 

Resolution

To have the sign in work properly, you need to manually go to your browser's settings and clear all the cache and cached files. Each Browser will have a different method to clear the cache but essentially it will be in the Settings under Privacy and Security. 

If you still have issues, please create a ticket in the Support Portal