When clicking the download button for resources in the KeyShot Cloud Library, nothing happens. The resources do not appear in the Resource Library within KeyShot
Issue
KeyShot Cloud Library Resources do not appear in the Resource Library within KeyShot after clicking the 'Download' button in the Cloud Library.
Environment Details
- KeyShot
- Any versions
- KeyShot Cloud Library accessed within any browser
Cause
- KeyShot Cloud Handler permissions have not been set properly.
Resolution
When clicking on the download option in the KeyShot Cloud Library within the browser for the first time, you may see a pop-up box appear with the following message:
Be sure to select 'Open KeyShotCloudHandler'. If you have selected 'Cancel', this may cause the Cloud Handler not to open which will cause the download not to occur. This message should show up on any browser and on Windows or Mac machines.
If even after you have clicked 'Open KeyShotCloudHandler' the download does not appear, on the Mac please be sure to enable System Events per the instructions below:
Enabling System Events on Mac
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Go to System Settings from your Apple Menu
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Select 'Privacy & Security' in the left side panel
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Select Automation
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Click on 'KeyShotCloudHandler' and make sure that 'System Events' is turned on
If you are still experiencing the issue after enabling System Events, please create a support ticket in our Support Portal so that we can assist you.