Error: "Could not save configuration to" when saving settings in KeyShot

This article provides instructions on how to troubleshoot and resolve the issue of being unable to save configuration settings in KeyShot.

Issue

When trying to save settings in KeyShot, the following error occurs:

Could not save configuration to C:\Users\Public\Documents\KeyShot xx\KSxxSettings.xml. Please check permissions for writing to this file.

xx is the specific version of KeyShot.

i.e. "Could not save configuration to C:\Users\Public\Documents\KeyShot 11\KS11Settings.xml. Please check permissions for writing to this file."

 

Environment Details

  • KeyShot
    • Any versions

Cause

  • Lack of permissions on the listed folder.

Resolution

Assign the proper permissions to the listed folder.

How to set folder permissions on Windows:

  1. Go to your Documents folder (C:\Users\Public\Documents)
  2. Right-click the KeyShot 11 folder.
  3. Select “Properties”.
  4. Uncheck “Read-only”.
  5. Go to the Security tab.
  6. Click the Edit button. Ensure that all users have read & execute and write permissions.
  7. Click Apply and OK.
  8. Click Apply and OK once more.

How to set folder permissions on Mac:

  1. Browse to the Macintosh HD\Library\Application Support folder.
  2. Right-click the KeyShot folder and select “Get Info”.
  3. Scroll down to Sharing & Permissions and make sure all users have both Read & Write.
    1. If you don't see your username in the list click the + and add your username, then give read and write permission. 
  4. Click the settings button (gear icon) select “Apply to enclosed items” and confirm.
  5. Close the Get Info window.
If you are unable to make these changes, then you will need to contact your internal IT admin to do this for you.

Additional Resources