The error "failed getting endpoint." occurs and KeyShot will not function when trying to activate KeyShot
Issue
When launching or rendering in KeyShot, the following error occurs:
Failed getting endpoint. Make sure you are connected to the Internet.
Environment Details
- KeyShot Studio
- Version 2023.2 and higher
- Subscription License Key
- Internet Web Browser
- Chrome
- Firefox
- Safari
Cause
- Security Internet Browser settings or Firewall settings.
Resolution
Solution 1
Please try a fresh install using the full installer:
-
Uninstall KeyShot.
Windows: Uninstall through Add/Remove Programs.
Mac: Uninstall by going to the Applications folder and Deleting the KeyShot app.
-
Make sure to delete the KeyShot resources folder
Note: Move it to the desktop if you wish to back up your resources.
Windows Default:* C:\Users\UserName\Documents\KeyShot or
* C:\Users\Public\Documents\KeyShot
* Delete C:\ProgramData\Luxion\KeyShot folder
* Delete C:\Users\%username%\AppData\Local\Luxion\KeyShot folder
Mac Default:/Library/Application Support/KeyShot
-
Download and Re-install KeyShot using the links below.
For this step, you’ll need the full installer (not the "update" installer).
You can find the newest version of KeyShot here.
You can find older versions of KeyShot here.
-
Go through the registration wizard, enter your license information, and KeyShot should be up and running.
Solution 2
Change the default Internet Web browser on your machine. For example, if your default Web browser is set to Firefox, change it to Chrome or Safari.
- Close KeyShot Studio.
- Change the current default browser to another browser:
- Open KeyShot and re-test the issue.
Note: The links above will navigate to a non-affiliated site of KeyShot. Consult your IT admin on how to change the default browser settings on your OS.
Solution 2
Add the following KeyShot URLs to the Firewall Whitelist for the organization:
- *.keyshot.io
- *.keyshot.com
- https://login-configuration.keyshot.com
- https://login.keyshot.com
- https://app.keyshot.com
- https://cognito-idp.us-east-2.amazonaws.com
Note: Contact your Network IT department to assist in adding these entries.
Solution 3
Clear cache in KeyShot Studio.
- In KeyShot, go to File > Sign out and exit. (This is important to disconnect any "remembered" users.)
- Delete the KS12Settings.xml file to clear any cached data.
- If installed as "Just for Me", go to - C:\Users\<username>\AppData\Local\KeyShot12
- If installed as "For Everyone", go - C:\Users\Public\Documents\KeyShot 12
- Restart KeyShot and re-test the issue.