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Error: Plugin Folder is Invalid

After installing KeyShot, when trying to open the application the error 'Plugin Folder is Invalid' shows

 

Issue

This issue specifically occurs on MacOS.

After installing KeyShot, when trying to open the application the error 'Plugin Folder is Invalid' shows as below:

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Environment Details

  • KeyShot
    • Any version
  • MacOS
    • Any version

Cause

  • An issue may have occurred during installation
  • The error can also be related to having more than one version of KeyShot installed on the computer. It may be referencing the Resource folder of the older version.

Resolution

We recommend the following solutions:

Solution 1

Please try a fresh install using the full installer:

  1. Uninstall KeyShot.

    Mac: Uninstall by going to the Applications folder and Deleting the KeyShot app.

  2. Make sure to delete the KeyShot  resources folder

    Note: Move it to the desktop if you wish to back up your resources.

    Mac Default:

    /Library/Application Support/KeyShot

  3. Download and Re-install KeyShot using the links below.

    For this step, you’ll need the full installer (not the "update" installer).

    You can find the newest version of KeyShot here. You will need to either enter your information or login to your KeyShot Cloud Account to access the installers.

    You can find older versions of KeyShot here.

  4. Go through the registration wizard, enter your license information, and KeyShot should be up and running.

Solution 2

This solution can be done in conjunction with Solution 1. We recommend uninstalling the older version of KeyShot you have on the computer. 

Solution 3

The issue may also be related to folder permissions. 

Please navigate to this folder: MacHD/Library/Application Support/KeyShot Studio

If you right-click the folder and select 'Get info', you should get a pop-up like this. Then check the 'Sharing & Permissions' settings and make sure they are set to 'Read & Write'.