Error: "Failed to get configuration from KeyShot Hub"

Customer will receive this error when trying to connect to the Hub - "Failed to get configuration from KeyShot Hub"

Issue

Users receive the following error when trying to connect to the Hub:

"Failed to get configuration from KeyShot Hub"

Environment Details

  • KeyShot | KeyShot Hub
    • Any versions

Cause

  • HTTP (80) Port needs to be opened through the Firewall. If not, this error will occur
  • May also occur if the redirect URL is not let through the Firewall

Workaround

  1. Open port HTTP (80) via Firewall. Developers are working to change the port to an HTTPS port. 
  2. You should whitelist [http://*.digizuite.app/]*.digizuite.app

    If you do not want to whitelist a wildcard, you need to whitelist or add a TLS inspection bypass the specific URLs that are part of the redirect when trying to access the Hub via KeyShot Studio.


If you have any questions, please open up a Support Ticket in the Support Porta.