Issue
I'm not able to connect to the license server system. The following error occurs:
Operation now in progress
Environment
- Windows OS
- Any version
- Mac OS
- Any version
- KeyShot License Server
- Any version
Cause
This error code can appear if there is another instance of the Luxion License Server already running on your host computer.
Resolution
Below you will find a guide as to how to check and stop any open License Server applications.
On a MacOS:
- Close the LuxionLicenseServer application.
- Open a Terminal.
- Use the command:
ps -ax
- This will give a list of all applications currently running, it is more detailed than the one in activity monitor.
- This list is sorted by the PID.
- Locate the license server process called something along the lines of: LuxionLicenseServer.app.
- Note the PID.
- In my case it was 111, but I believe this varies
- Use the command:
sudo kill -9 <PID>
- In example: sudo kill -9 111
- rerun ps -ax and verify no "lmgrd" or "LUXION" application is running.
- Use the command:
cd /var/tmp
- Use the command:
ls -l
- You should see an entry like: -rw-r--r-- 1 root wheel 0 Dec 16 14:49 lockLUXION
- If you don't see that file continue to step 11.
- Use the command:
rm lockLUXION
- Note you may need to use sudo rm lockLUXION
- You are now done.
- Open the LuxionLicenseServer application and setup as normal
If this fails:
- Open the terminal and enter:
sudo nano /etc/hosts
- Check to see if the hostname used in the license file is listed.
- If not, add a static IP address and the hostname from the license file.
- Press CTRL + O, followed by Enter to overwrite the previous information.
- Press CTRL + X to exit.
- Launch the Luxion License Server app and press Install License.
- Browse to where the license file is located and re-install the license.
- The server should start automatically, press 'Status' to check if the server is running.
- If there is still an error, make a copy of the message and open a ticket with Support using the Customer Portal.
On a Windows OS:
- Close the LuxionLicenseServer application.
- Open the Task Manager.
- Search for any running programs named Luxion License Server.
- If found, right-click the program and select 'End Task'.
- Open the LuxionLicenseServer application to see if the problem as been solved.
If this fails:
- Stop and close the Luxion License server, then hit the 'windows' key and enter 'LMTools'.
- Open LMTools and select the 'Start/Stop/Reread' tab.
- If this tab shows that the server is started, click stop.
- Start the service to see if it launches. You will see a small message at the bottom of the LMTools windows stating if it started or not.
- If it does not start, select the 'Config Services' tab and select 'View Log'.
- Make a copy of this log and send it to Support by submitting a ticket on the Customer Portal.