Error: "Failed to parse the JWT response. (error = 7)" when activating a KeyShot license

Getting the error "failed to parse the JWT response" when launching KeyShot.

Issue


After launching KeyShot and activating a KeyShot license, the following error below occurs:

Failed to parse the JWT response. (error = 7)Please check that your system date, time, and time zone are correct:


Environment Details

  • KeyShot
    • Any versions

Cause

A subscription license has to be validated every 7 calendar days. The error can occur because of the following:

  • KeyShot is left on overnight
  • The logged-in user has not logged out correctly before restarting
  • The computer's system time and Timezone are out of sync or not set correctly
  • KeyShot can save the previous authentication token's date and time, causing it to expire

Solution 1

If you have not done so already, please restart your computer to clear the authentication token and confirm that your computer's date and time match the current time zone you are in.

Solution 2

The JWT error is ultimately related to the time difference between our servers and the users computers. If they still receive the error, it means that the time is syncing with our server's time. The server is set to be on the internet time. Even if it is off by 1 minute, it will throw this error. 
I would recommend trying the following:
If you notice that the internet time is showing your company name, then it might be syncing to a server on your network and you would need to ask your IT team to update the time as there can be an issue if the time falls behind even 1 minute.  Another option would be to go to the 'Date & Time' settings and Turn off and back on the 'Set Time Automatically' option.

Solution 3

Syncing the time manually: (These instructions are for a Windows machine)
1. Right-click the date and time on the bottom right panel:
2. Select 'Adjust date and time'.
3. Turn off 'Set time automatically'.
4. Select the 'change button'.
5. Enter the exact time and date you see on your phone connected to the internet.

Solution 4

Be sure to check if your Internet time is correct. Even if your local computer's time is correct, if the Internet time is wrong you can still get this error message. You can compare this against your cell phone's time or on sites like https://www.timeanddate.com/. If it is so much as a second off, it can trigger this issue.
If you notice that the internet time is showing your company name, then it might be syncing to a server on your network and you would need to ask your IT team to update the time as there can be an issue if the time falls behind even 1 minute or less.

If both solutions fail, please send a copy of the cloud_auth_error logs and your KeyShot.log file.
 

On Mac OS, they should be located in either:

  • /Users/<Username>/Library/Application Support/Luxion/KeyShot
  • ~/Library/Application Support/Luxion/KeyShot 
Windows
  • %AllUsersProfile%\Luxion\KeyShot
  • C:\ProgramData\Luxion\KeyShot
  • %LocalAppData%\Luxion\KeyShot
  • C:\Users\<username>\AppData\Local\Luxion\KeyShot