The floating license server status shows a No socket connection to license server manager error.
Issue
Environment Details
- KeyShot
- Version 10 or higher
Cause
- This error message means the connection was broken due to disconnection from the network, however, the system has initiated roaming to another access point.
- The default ports are being used.
- VPN or Firewall setting is stopping the connection.
Resolution
1. Please confirm that ports 27000-27010 are available in your network firewall.
2. If you have a Firewall or have other License servers running on the same machine you may need to change the Server Ports, this can be done by clicking the Server Ports button.
- FlexLM Port: Change this to avoid port conflicts If you have other License servers - the default is 27000.
- Deamon Port: This is only used for network setups with a Firewall. If a Firewall is used, both ports need to be set and opened in the Firewall.
NOTE: Please discuss this in detail with your IT department before assigning ports. Once the ports have been assigned, start the Luxion License server and re-test the issue.
If errors persist, you may contact Support and send the following information:
For Windows:
- Stop and close the Luxion License server, then hit the 'windows' key and enter 'LMTools'.
- Open LMTools and select the 'Start/Stop/Reread' tab.
- If this tab shows that the server is started, click stop.
- Start the service to see if it launches. You will see a small message at the bottom of the LMTools windows stating if it started or not.
- If it does not start, select the 'Config Services' tab and select 'View Log'.
-
Make a copy of this log and contact Support.
- Stop the Luxion License server and select the License Folder button
- Find the file LUXION.log
- Make a copy of this file and contact Support.