Optix error: 7012 (Disk cache database error)

Issue

When trying to activate GPU mode, user gets an error message saying 'Optix error: 7012 (Disk cache database error)

Error: Optix error: 7012 (Disk cache database error)

Environment Details

  • KeyShot 
    • Any version
  • Windows computer with GPU Card

Cause

  • There may be an issue with the optix7cache.db file

Resolution

Solution 1:

First, make sure that KeyShot is closed. 

If KeyShot is installed in the default location, go to C:\Users\Public\Documents\KeyShot Studio (or the folder that corresponds with your version) and delete the optix7cache.db file. After you do that, start KeyShot and see if you still receive the same errors.
Also, make sure to update your GPU drivers to the most current version. You can use Nvidia's tool to search for the most recent driver here

Solution 2:

Try a Fresh Install if the other options do not work (see instructions below).

Please try a fresh install using the full installer:

  1. Uninstall KeyShot.

    Windows: Uninstall through Add/Remove Programs.

  2. Make sure to delete the KeyShot  resources folder

    Note: Move it to the desktop if you wish to back up your resources.
    Windows Default:

    * C:\Users\UserName\Documents\KeyShot or

    * C:\Users\Public\Documents\KeyShot

    * Delete C:\ProgramData\Luxion\KeyShot folder

    * Delete C:\Users\%username%\AppData\Local\Luxion\KeyShot folder

  3. Download and Re-install KeyShot using the links below.

    For this step, you’ll need the full installer (not the "update" installer).

    You can find the newest version of KeyShot here. You will need to either enter your information or login to your KeyShot Cloud Account to access the installers.

    You can find older versions of KeyShot here.

  4. Go through the registration wizard, enter your license information, and KeyShot should be up and running.

If you still experience issues, please contact support by creating a ticket in the support portal