KeyShot Library is not loading

A troubleshooting guide for issues related to the Library

Issue

You may find that your Library is not loading completely or at all or that folders are invalid.

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Environment Details

  • KeyShot
    •  Any versions

Cause

  • The location of the Resource Folder might not have write permissions
  • The Resource Folder might be on a shared or network drive
  • The Resource Folder could be getting offloaded to a Cloud.

Resolution

Solution 1

Please try a fresh install using the full installer:
Make sure to

  • back up your custom resources
  • install to the default location or a location you know to be writable
  • install to a local drive, not a share or network drive
  1. Uninstall KeyShot.

    Windows: Uninstall through Add/Remove Programs.

    Mac: Uninstall by going to the Applications folder and Deleting the KeyShot app.

  2. Make sure to delete the KeyShot  resources folder

    Note: Move it to the desktop if you wish to back up your resources.


    Windows Default:

    * C:\Users\UserName\Documents\KeyShot or

    * C:\Users\Public\Documents\KeyShot

    * Delete C:\ProgramData\Luxion\KeyShot folder

    * Delete C:\Users\%username%\AppData\Local\Luxion\KeyShot folder


    Mac Default:

    /Library/Application Support/KeyShot

  3. Download and Re-install KeyShot using the links below.

    For this step, you’ll need the full installer (not the "update" installer).

    You can find the newest version of KeyShot here. You will need to either enter your information or login to your KeyShot Cloud Account to access the installers.

    You can find older versions of KeyShot here.

  4. Go through the registration wizard, enter your license information, and KeyShot should be up and running.

Solution 2

If the Resource Folder is being synchronized with a Cloud, e.g. is in OneDrive, please ensure that the Resource Folder is always kept on the local device.

Solution 3

If the default location is not writable, which on Windows is

  • if installed Just For Me:
    C:\Users\<username>\AppData\Local\KeyShot or %UserProfile%\Local\KeyShot
  • if installed For Everybody:
    C:\Program Files\KeyShot or %ProgramFiles%\KeyShot 

The Resource Folder with the actual resources can be specified in the installer.
However the Settings Folder will always be installed to the default location.
This can only be changed through the registry.

  • if installed Just For Me:
    Computer\HKEY_CURRENT_USER\Software\Luxion\KeyShot
  • if installed For Everybody:
    Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Luxion\KeyShot

The last two values are the ResourceFolder and Resources.
The Resources are the resources like Textures, Scenes, Materials, etc.
The ResourceFolder on the other hand are the Settings and will by default be in the default installation location.
If that is not writable, you can move the files to a different folder and adjust the ResourceFolder value accordingly.

IMPORTANT: Editing the Windows Registry incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of the Windows Registry can be solved. Use the Windows Registry at your own risk. It's highly recommended to consult your IT administrator before making changes to create backups for disaster recovery purposes.


Additional Resources