KeyShot Uninstaller not working

After running the KeyShot uninstaller, KeyShot still appears on the computer

Issue

After running the KeyShot uninstaller and it confirms the uninstall is complete, KeyShot still appears on the Installed Program list and is able to be launched with no issue. Running the uninstaller multiple times does not resolve the issue. 

Environment Details

  • KeyShot
    • Any versions
  • Security-forward identity and access management software such as CyberArk

Cause

  • The identity and access management software, such as CyberArk, is not able to recognize an uninstaller application when triggered through Window’s new Installed Programs menu in Window’s Settings to set the correct access. The KeyShot uninstaller does not work properly without the correct access/control.

Resolution

The suggested workaround is to run the uninstaller from the .exe itself.